BETA

13th December 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [13/12/19 12:00 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/12/19 01:00 PM]