BETA

13th December 2019

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [13/12/19 11:50 AM] with 'Major Outage'

Issue has been resolved at [13/12/19 12:00 PM]