BETA

13th December 2019

Madhya Pradesh Issue observed for 'Incoming Calls' in Madhya Pradesh Region

Identified at [13/12/19 11:40 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/12/19 12:10 PM]