BETA

30th May 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [30/05/17 06:12 PM] with 'Partial Outage'

Issue has been resolved at [30/05/17 06:13 PM]