BETA

13th December 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [13/12/19 11:20 AM] with 'Major Outage'

Issue has been resolved at [13/12/19 11:30 AM]