BETA

23rd May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [23/05/17 09:31 AM] with 'Partial Outage'

Issue has been resolved at [23/05/17 09:32 AM]