BETA

13th December 2019

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [13/12/19 10:20 AM] with 'Major Outage'

Issue has been resolved at [13/12/19 10:30 AM]