BETA

13th December 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [13/12/19 10:00 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/12/19 11:00 AM]