BETA

13th December 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [13/12/19 09:50 AM] with 'Major Outage'

Issue has been resolved at [13/12/19 10:40 PM]