BETA

13th December 2019

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [13/12/19 06:59 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/12/19 09:19 AM]