BETA

13th December 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [13/12/19 01:20 AM] with 'Major Outage'

Issue has been resolved at [13/12/19 01:29 AM]