BETA

13th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [13/12/19 12:09 AM] with 'Partial Outage'

Issue has been resolved at [13/12/19 12:10 AM]