BETA

22nd May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [22/05/17 11:56 AM] with 'Major Outage'

Issue has been resolved at [22/05/17 11:59 AM]