BETA

12th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/12/19 06:29 PM] with 'Partial Outage'

Issue has been resolved at [12/12/19 06:30 PM]