BETA

12th December 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [12/12/19 03:40 PM] with 'Partial Outage'

Issue has been resolved at [12/12/19 03:50 PM]