BETA

22nd May 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [22/05/17 10:57 AM] with 'Partial Outage'

Issue has been resolved at [22/05/17 10:59 AM]