BETA

12th December 2019

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/12/19 01:09 PM] with 'Major Outage'

Issue has been resolved at [12/12/19 01:10 PM]