BETA

12th December 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/12/19 12:59 PM] with 'Major Outage'

Issue has been resolved at [12/12/19 01:09 PM]