BETA

12th December 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [12/12/19 12:19 PM] with 'Major Outage'

Issue has been resolved at [12/12/19 12:30 PM]