BETA

12th December 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [12/12/19 10:59 AM] with 'Major Outage'

Issue has been resolved at [12/12/19 01:29 PM]