BETA

22nd May 2017

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [22/05/17 12:29 AM] with 'Partial Outage'

Issue has been resolved at [22/05/17 12:30 AM]