BETA

12th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [12/12/19 09:30 AM] with 'Partial Outage'

Issue has been resolved at [12/12/19 09:49 AM]