BETA

22nd May 2017

Andhra Pradesh Issue observed for 'Incoming Calls' in Andhra Pradesh Region

Identified at [22/05/17 12:29 AM] with 'Major Outage'

Issue has been resolved at [22/05/17 12:31 AM]