BETA

11th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/12/19 04:49 PM] with 'Partial Outage'

Issue has been resolved at [11/12/19 05:00 PM]