BETA

11th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/12/19 02:20 PM] with 'Partial Outage'

Issue has been resolved at [11/12/19 02:29 PM]