BETA

11th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [11/12/19 10:10 AM] with 'Major Outage'

Issue has been resolved at [11/12/19 10:20 AM]