BETA

11th December 2019

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [11/12/19 09:59 AM] with 'Major Outage'

Issue has been resolved at [11/12/19 10:20 AM]