BETA

11th December 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [11/12/19 09:59 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/12/19 10:20 AM]