BETA

16th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [16/03/19 08:14 AM] with 'Partial Outage'

Issue has been resolved at [16/03/19 08:15 AM]