BETA

11th December 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [11/12/19 01:39 AM] with 'Major Outage'

Issue has been resolved at [11/12/19 01:49 AM]