BETA

11th December 2019

Chennai Issue observed for 'Incoming Calls' in Chennai Region

Identified at [11/12/19 01:29 AM] with 'Major Outage'

Issue has been resolved at [11/12/19 01:39 AM]