BETA

11th December 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [11/12/19 01:00 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/12/19 01:19 AM]