BETA

21st May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [21/05/17 10:30 PM] with 'Partial Outage'

Issue has been resolved at [21/05/17 10:31 PM]