BETA

11th December 2019

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [11/12/19 12:30 AM] with 'Major Outage'

Issue has been resolved at [11/12/19 02:10 AM]