BETA

11th December 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [11/12/19 12:29 AM] with 'Partial Outage'

Issue has been resolved at [11/12/19 12:39 AM]