BETA

10th December 2019

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [10/12/19 02:39 PM] with 'Partial Outage'

Issue has been resolved at [10/12/19 02:49 PM]