BETA

10th December 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [10/12/19 01:19 PM] with 'Major Outage'

Issue has been resolved at [10/12/19 01:39 PM]