BETA

20th May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [20/05/17 03:34 AM] with 'Partial Outage'

Issue has been resolved at [20/05/17 03:35 AM]