BETA

10th December 2019

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [10/12/19 10:49 AM] with 'Partial Outage'

Issue has been resolved at [10/12/19 10:50 AM]