BETA

8th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [08/12/19 11:15 AM] with 'Major Outage'

Issue has been resolved at [08/12/19 11:24 AM]