BETA

17th May 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [17/05/17 05:48 AM] with 'Partial Outage'

Issue has been resolved at [17/05/17 05:49 AM]