BETA

7th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [07/12/19 12:15 PM] with 'Major Outage'

Issue has been resolved at [07/12/19 12:44 PM]