BETA

7th December 2019

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [07/12/19 12:14 PM] with 'Partial Outage'

Issue has been resolved at [07/12/19 12:34 PM]