BETA

5th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [05/12/19 01:15 PM] with 'Partial Outage'

Issue has been resolved at [05/12/19 01:24 PM]