BETA

5th December 2019

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [05/12/19 12:54 PM] with 'Partial Outage'

Issue has been resolved at [05/12/19 01:14 PM]