BETA

4th December 2019

Rajasthan Issue observed for 'Incoming Calls' in Rajasthan Region

Identified at [04/12/19 12:25 PM] with 'Partial Outage'

Issue has been resolved at [04/12/19 12:35 PM]