BETA

4th December 2019

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [04/12/19 12:15 PM] with 'Major Outage'

Issue has been resolved at [04/12/19 12:25 PM]