BETA

4th December 2019

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [04/12/19 09:54 AM] with 'Partial Outage'

Issue has been resolved at [04/12/19 10:54 AM]