BETA

1st December 2019

Pune Issue observed for 'Incoming Calls' in Pune Region

Identified at [01/12/19 11:44 AM] with 'Major Outage'

Issue has been resolved at [01/12/19 11:45 AM]