BETA

1st December 2019

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [01/12/19 01:34 AM] with 'Major Outage'

Issue has been resolved at [01/12/19 01:35 AM]